// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\[img\].+\n)(\[img\].+\n)*").unwrap();
let string = "subject1
image url follows here
[img]http:f6.abc.com/246421f...
[img]http:f6.abc.com/246421d...
[img]http:f6.abc.com/246421h...
[img]http:f6.abc.com/246421m...
download url follows here
[url]link1[/url]
subject2
image url follows here
[img]http:z.uvw.com/7862252...
[img]http:z.uvw.com/4621017...
[img]http:z.uvw.com/4728212...
[img]http:z.uvw.com/78293.5...
download url follows here
[url]link2[/url]";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}