#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Tornado Warning for\.\.\.(?:\n.*)*?\n\n"
Local $sString = "The National Weather Service in Milwaukee/Sullivan has issued a" & @CRLF & _
"" & @CRLF & _
"* Tornado Warning for..." & @CRLF & _
"Northwestern Columbia County in south central Wisconsin..." & @CRLF & _
"Southwestern Marquette County in south central Wisconsin..." & @CRLF & _
"" & @CRLF & _
"* Until 945 PM CDT." & @CRLF & _
"" & @CRLF & _
"* At 911 PM CDT, a severe thunderstorm capable of producing a tornado" & @CRLF & _
"was located 8 miles east of Wisconsin Dells, moving northeast at 45" & @CRLF & _
"mph." & @CRLF & _
"" & @CRLF & _
"HAZARD...Tornado." & @CRLF & _
"" & @CRLF & _
"SOURCE...Radar indicated rotation." & @CRLF & _
"" & @CRLF & _
"IMPACT...Flying debris will be dangerous to those caught without" & @CRLF & _
"shelter. Mobile homes will be damaged or destroyed." & @CRLF & _
"Damage to roofs, windows, and vehicles will occur. Tree" & @CRLF & _
"damage is likely." & @CRLF & _
"" & @CRLF & _
"* Locations impacted include..." & @CRLF & _
"Packwaukee, Endeavor and Briggsville."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")