import Foundation
let pattern = #"Tornado Warning for\.\.\.(?:\n.*)*?\n\n"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
The National Weather Service in Milwaukee/Sullivan has issued a
* Tornado Warning for...
Northwestern Columbia County in south central Wisconsin...
Southwestern Marquette County in south central Wisconsin...
* Until 945 PM CDT.
* At 911 PM CDT, a severe thunderstorm capable of producing a tornado
was located 8 miles east of Wisconsin Dells, moving northeast at 45
mph.
HAZARD...Tornado.
SOURCE...Radar indicated rotation.
IMPACT...Flying debris will be dangerous to those caught without
shelter. Mobile homes will be damaged or destroyed.
Damage to roofs, windows, and vehicles will occur. Tree
damage is likely.
* Locations impacted include...
Packwaukee, Endeavor and Briggsville.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)