# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Tornado Warning for\.\.\.(?:\n.*)*?\n\n"
test_str = ("The National Weather Service in Milwaukee/Sullivan has issued a\n\n"
"* Tornado Warning for...\n"
"Northwestern Columbia County in south central Wisconsin...\n"
"Southwestern Marquette County in south central Wisconsin...\n\n"
"* Until 945 PM CDT.\n\n"
"* At 911 PM CDT, a severe thunderstorm capable of producing a tornado\n"
"was located 8 miles east of Wisconsin Dells, moving northeast at 45\n"
"mph.\n\n"
"HAZARD...Tornado.\n\n"
"SOURCE...Radar indicated rotation.\n\n"
"IMPACT...Flying debris will be dangerous to those caught without\n"
"shelter. Mobile homes will be damaged or destroyed.\n"
"Damage to roofs, windows, and vehicles will occur. Tree\n"
"damage is likely.\n\n"
"* Locations impacted include...\n"
"Packwaukee, Endeavor and Briggsville.")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.