using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Tornado Warning for\.\.\.(?:\n.*)*?\n\n";
string input = @"The National Weather Service in Milwaukee/Sullivan has issued a
* Tornado Warning for...
Northwestern Columbia County in south central Wisconsin...
Southwestern Marquette County in south central Wisconsin...
* Until 945 PM CDT.
* At 911 PM CDT, a severe thunderstorm capable of producing a tornado
was located 8 miles east of Wisconsin Dells, moving northeast at 45
mph.
HAZARD...Tornado.
SOURCE...Radar indicated rotation.
IMPACT...Flying debris will be dangerous to those caught without
shelter. Mobile homes will be damaged or destroyed.
Damage to roofs, windows, and vehicles will occur. Tree
damage is likely.
* Locations impacted include...
Packwaukee, Endeavor and Briggsville.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}