#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[^0-9.]"
Local $sString = "02. ГудВин[Герои Комиксов] - Орут сирены(фристайл)" & @CRLF & _
"12. Стильный Билли feat. aka Ахмед - Чисто ё (Стильный Билли prod.)" & @CRLF & _
"04.Nuttkase feat. Птаха - Если Друг (Хасол-Версия) (Phunk Masta Seven prod.)" & @CRLF & _
"02.Dr.MokRolog,Old Primus,JustSmile,Vine Bi - Электрограч (Pro100 Beatz prod.)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")