package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^0-9.]`)
var str = `02. ГудВин[Герои Комиксов] - Орут сирены(фристайл)
12. Стильный Билли feat. aka Ахмед - Чисто ё (Стильный Билли prod.)
04.Nuttkase feat. Птаха - Если Друг (Хасол-Версия) (Phunk Masta Seven prod.)
02.Dr.MokRolog,Old Primus,JustSmile,Vine Bi - Электрограч (Pro100 Beatz prod.)`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}