const regex = /[^0-9.]/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^0-9.]', '')
const str = `02. ГудВин[Герои Комиксов] - Орут сирены(фристайл)
12. Стильный Билли feat. aka Ахмед - Чисто ё (Стильный Билли prod.)
04.Nuttkase feat. Птаха - Если Друг (Хасол-Версия) (Phunk Masta Seven prod.)
02.Dr.MokRolog,Old Primus,JustSmile,Vine Bi - Электрограч (Pro100 Beatz prod.)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}