use strict;
my $str = '02. ГудВин[Герои Комиксов] - Орут сирены(фристайл)
12. Стильный Билли feat. aka Ахмед - Чисто ё (Стильный Билли prod.)
04.Nuttkase feat. Птаха - Если Друг (Хасол-Версия) (Phunk Masta Seven prod.)
02.Dr.MokRolog,Old Primus,JustSmile,Vine Bi - Электрограч (Pro100 Beatz prod.)';
my $regex = qr/[^0-9.]/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}