const regex = /{\K([A-Z0-9]{8})_([A-Z0-9]{4})_([A-Z0-9]{4})_([A-Z0-9]{4})_([A-Z0-9]{12})(?=})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('{\\K([A-Z0-9]{8})_([A-Z0-9]{4})_([A-Z0-9]{4})_([A-Z0-9]{4})_([A-Z0-9]{12})(?=})', 'gm')
const str = `{89695C16_C0FF_4E7C_9BB2_8B50FAC9D371}`;
const subst = `$1-$2-$3-$4-$5`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);