re = /{\K([A-Z0-9]{8})_([A-Z0-9]{4})_([A-Z0-9]{4})_([A-Z0-9]{4})_([A-Z0-9]{12})(?=})/m
str = '{89695C16_C0FF_4E7C_9BB2_8B50FAC9D371}'
subst = '$1-$2-$3-$4-$5'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result