import Foundation
let pattern = #"{\K([A-Z0-9]{8})_([A-Z0-9]{4})_([A-Z0-9]{4})_([A-Z0-9]{4})_([A-Z0-9]{12})(?=})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"{89695C16_C0FF_4E7C_9BB2_8B50FAC9D371}"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1-$2-$3-$4-$5"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)