# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(http:\/\/.*?)(?=\sxmlns|>)/"\1"/g;t' <<< "<soapenv:Envelope xmlns:soapenv=http://schemas.xmlsoap.org/soap/envelope/ xmlns:soap=http://www.4cgroup.co.za/soapauth xmlns:gen=http://www.4cgroup.co.za/genericsoap>
"