re = /(http:\/\/.*?)(?=\sxmlns|>)/
str = '<soapenv:Envelope xmlns:soapenv=http://schemas.xmlsoap.org/soap/envelope/ xmlns:soap=http://www.4cgroup.co.za/soapauth xmlns:gen=http://www.4cgroup.co.za/genericsoap>
'
subst = '"\\1"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result