import Foundation
let pattern = #"(http://.*?)(?=\sxmlns|>)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<soapenv:Envelope xmlns:soapenv=http://schemas.xmlsoap.org/soap/envelope/ xmlns:soap=http://www.4cgroup.co.za/soapauth xmlns:gen=http://www.4cgroup.co.za/genericsoap>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""\1""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)