using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(http://.*?)(?=\sxmlns|>)";
string substitution = @"""\1""";
string input = @"<soapenv:Envelope xmlns:soapenv=http://schemas.xmlsoap.org/soap/envelope/ xmlns:soap=http://www.4cgroup.co.za/soapauth xmlns:gen=http://www.4cgroup.co.za/genericsoap>
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}