using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\$\w+\['|\G(?!^))\w+\K\h+(?=[^][]*'])";
string substitution = @"";
string input = @"$lang['Delivery Charge'] = 'Delivery Charge';
$lang['Frequently Asked Questions'] = 'Frequently Asked Questions';";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}