$re = '/(?:\$\w+\[\'|\G(?!^))\w+\K\h+(?=[^][]*\'])/m';
$str = '$lang[\'Delivery Charge\'] = \'Delivery Charge\';
$lang[\'Frequently Asked Questions\'] = \'Frequently Asked Questions\';';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;