re = /(?:\$\w+\['|\G(?!^))\w+\K\h+(?=[^][]*'])/m
str = '$lang[\'Delivery Charge\'] = \'Delivery Charge\';
$lang[\'Frequently Asked Questions\'] = \'Frequently Asked Questions\';'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result