import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\$\\w+\\['|\\G(?!^))\\w+\\K\\h+(?=[^][]*'])";
final String string = "$lang['Delivery Charge'] = 'Delivery Charge';\n\n"
+ "$lang['Frequently Asked Questions'] = 'Frequently Asked Questions';";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}