package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\b((?:Rs|EURO|DNR)\s*)\d+`)
var str = `0 RS 125 | password1
1 EURO 25 | password2
2 DNR 30 | password3
2 BDNR 30 | password3`
var substitution = "\g<1>100"
fmt.Println(re.ReplaceAllString(str, substitution))
}