// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\b((?:Rs|EURO|DNR)\s*)\d+").unwrap();
let string = "0 RS 125 | password1
1 EURO 25 | password2
2 DNR 30 | password3
2 BDNR 30 | password3";
let substitution = "\\g<1>100";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}