import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)\\b((?:Rs|EURO|DNR)\\s*)\\d+";
final String string = "0 RS 125 | password1\n"
+ "1 EURO 25 | password2\n"
+ "2 DNR 30 | password3\n"
+ "2 BDNR 30 | password3";
final String subst = "\\g<1>100";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}