$re = '/(?i)\b((?:Rs|EURO|DNR)\s*)\d+/';
$str = '0 RS 125 | password1
1 EURO 25 | password2
2 DNR 30 | password3
2 BDNR 30 | password3';
$subst = "\g<1>100";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;