using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"youtube\.com\/watch\?v\=([0-9a-zA-Z]+)";
string input = @"https://www.youtube.com/watch?v=blabla42";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}