package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)youtube\.com\/watch\?v\=([0-9a-zA-Z]+)`)
var str = `https://www.youtube.com/watch?v=blabla42`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}