re = /youtube\.com\/watch\?v\=([0-9a-zA-Z]+)/m
str = 'https://www.youtube.com/watch?v=blabla42'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end