import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "'.{5,}'";
final String string = "var obj = {\n"
+ " key1: 'xxxxx',\n"
+ " key2: 'xxxxx',\n"
+ " key3: 'xxxxx'\n"
+ "};\n"
+ "var obj1 = { key1: 'xxxxx', key2: 'xxxxx', key3: 'xxxxx' };";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}