re = /'.{5,}'/
str = 'var obj = {
key1: \'xxxxx\',
key2: \'xxxxx\',
key3: \'xxxxx\'
};
var obj1 = { key1: \'xxxxx\', key2: \'xxxxx\', key3: \'xxxxx\' };'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end