package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((\d+\.?)+)([^0-9. ]\S+)`)
var str = `01.11Выращивание зерновых (кроме риса), зернобобовых культур и семян масличных культур`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}