// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)((\d+\.?)+)([^0-9. ]\S+)").unwrap();
let string = "01.11Выращивание зерновых (кроме риса), зернобобовых культур и семян масличных культур";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}