const regex = /((\d+\.?)+)([^0-9. ]\S+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((\\d+\\.?)+)([^0-9. ]\\S+)', 'gm')
const str = `01.11Выращивание зерновых (кроме риса), зернобобовых культур и семян масличных культур`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}