$re = '/((\d+\.?)+)([^0-9. ]\S+)/m';
$str = '01.11Выращивание зерновых (кроме риса), зернобобовых культур и семян масличных культур';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);