import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\*\\s+<< BeReq\\s+>> (?P<request>\\d+) ?$\n"
+ "^-\\s+BackendOpen\\s+\\d+ (?P<backend>[^ ]+) .+$\n"
+ "^-\\s+BerespStatus\\s+(?P<status>\\d{3})$\n"
+ "^-\\s+Timestamp\\s+BerespBody: (?P<timestamp>[\\d.]+) (?P<response_time>[\\d.]+) .+$";
final String string = "* << BeReq >> 416335894 \n"
+ "- BackendOpen 137 boot.https_app3 10.1.10.8 8443 10.1.10.10 45467\n"
+ "- BerespStatus 200\n"
+ "- Timestamp BerespBody: 1536053067.307297 0.002362 0.000701\n\n"
+ "* << BeReq >> 417244880 \n"
+ "- BackendOpen 62 boot.https_app4 10.1.10.9 8443 10.1.10.10 50995\n"
+ "- BerespStatus 200\n"
+ "- Timestamp BerespBody: 1536053067.427519 0.120675 0.001029\n\n"
+ "* << BeReq >> 411778166\n"
+ "- BackendOpen 77 boot.https_app3 10.1.10.8 8443 10.1.10.10 39506\n"
+ "- BerespStatus 304\n"
+ "- BerespStatus 200\n"
+ "- Timestamp BerespBody: 1536052222.383470 0.009091 0.000151";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}