# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r"^\*\s+<< BeReq\s+>> (?P<request>\d+) ?$\n"
r"^-\s+BackendOpen\s+\d+ (?P<backend>[^ ]+) .+$\n"
r"^-\s+BerespStatus\s+(?P<status>\d{3})$\n"
r"^-\s+Timestamp\s+BerespBody: (?P<timestamp>[\d.]+) (?P<response_time>[\d.]+) .+$")
test_str = ("* << BeReq >> 416335894 \n"
"- BackendOpen 137 boot.https_app3 10.1.10.8 8443 10.1.10.10 45467\n"
"- BerespStatus 200\n"
"- Timestamp BerespBody: 1536053067.307297 0.002362 0.000701\n\n"
"* << BeReq >> 417244880 \n"
"- BackendOpen 62 boot.https_app4 10.1.10.9 8443 10.1.10.10 50995\n"
"- BerespStatus 200\n"
"- Timestamp BerespBody: 1536053067.427519 0.120675 0.001029\n\n"
"* << BeReq >> 411778166\n"
"- BackendOpen 77 boot.https_app3 10.1.10.8 8443 10.1.10.10 39506\n"
"- BerespStatus 304\n"
"- BerespStatus 200\n"
"- Timestamp BerespBody: 1536052222.383470 0.009091 0.000151")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.