const regex = new RegExp('^\\*\\s+<< BeReq\\s+>> (?P<request>\\d+) ?$
^-\\s+BackendOpen\\s+\\d+ (?P<backend>[^ ]+) .+$
^-\\s+BerespStatus\\s+(?P<status>\\d{3})$
^-\\s+Timestamp\\s+BerespBody: (?P<timestamp>[\\d.]+) (?P<response_time>[\\d.]+) .+$', 'gm')
const str = `* << BeReq >> 416335894
- BackendOpen 137 boot.https_app3 10.1.10.8 8443 10.1.10.10 45467
- BerespStatus 200
- Timestamp BerespBody: 1536053067.307297 0.002362 0.000701
* << BeReq >> 417244880
- BackendOpen 62 boot.https_app4 10.1.10.9 8443 10.1.10.10 50995
- BerespStatus 200
- Timestamp BerespBody: 1536053067.427519 0.120675 0.001029
* << BeReq >> 411778166
- BackendOpen 77 boot.https_app3 10.1.10.8 8443 10.1.10.10 39506
- BerespStatus 304
- BerespStatus 200
- Timestamp BerespBody: 1536052222.383470 0.009091 0.000151`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}