const regex = new RegExp('^SW(TS|L|M)-(\\d+)([:,] )([wW][iI][pP])?(?(4)[ \\w]{3,}|(?!([wW][iI][pP]))[ \\w]{3,}).*$', 'gm')
const str = `SWL-101
just did it
SWL-101: wip something is about to be done
SWL-102: wip
SWTS-103, we did something cool
SWM-104, i am groot!
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}