import re
regex = re.compile(r"^SW(TS|L|M)-(\d+)([:,] )([wW][iI][pP])?(?(4)[ \w]{3,}|(?!([wW][iI][pP]))[ \w]{3,}).*$", flags=re.MULTILINE)
test_str = ("SWL-101\n"
"just did it\n"
"SWL-101: wip something is about to be done\n"
"SWL-102: wip \n"
"SWTS-103, we did something cool\n"
"SWM-104, i am groot!\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")