re = /^SW(TS|L|M)-(\d+)([:,] )([wW][iI][pP])?(?(4)[ \w]{3,}|(?!([wW][iI][pP]))[ \w]{3,}).*$/m
str = 'SWL-101
just did it
SWL-101: wip something is about to be done
SWL-102: wip
SWTS-103, we did something cool
SWM-104, i am groot!
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end