using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[()]";
string input = @"SELECT JSON_OBJECT(
(KEY 'employee_name' VALUE e.ename ABSENT ON NULL,
KEY 'commission' VALUE e.comm
--ABSENT ON NULL
) AS employees
FROM emp e
WHERE e.deptno = 10;";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}