import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[()]";
final String string = "SELECT JSON_OBJECT(\n"
+ " (KEY 'employee_name' VALUE e.ename ABSENT ON NULL,\n"
+ " KEY 'commission' VALUE e.comm\n"
+ " --ABSENT ON NULL\n"
+ " ) AS employees\n"
+ "FROM emp e\n"
+ "WHERE e.deptno = 10;";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}