re = /[()]/m
str = 'SELECT JSON_OBJECT(
(KEY \'employee_name\' VALUE e.ename ABSENT ON NULL,
KEY \'commission\' VALUE e.comm
--ABSENT ON NULL
) AS employees
FROM emp e
WHERE e.deptno = 10;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end