$re = '/[()]/m';
$str = 'SELECT JSON_OBJECT(
(KEY \'employee_name\' VALUE e.ename ABSENT ON NULL,
KEY \'commission\' VALUE e.comm
--ABSENT ON NULL
) AS employees
FROM emp e
WHERE e.deptno = 10;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);