using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bwithout\b.*?(?:fragrances|colorants).*\bflavor\b";
string input = @"This product is without artificial fragrances, colorants and additional flavor.
This product without a doubt has the best flavor you will ever taste.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}