const regex = /\bwithout\b.*?(?:fragrances|colorants).*\bflavor\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bwithout\\b.*?(?:fragrances|colorants).*\\bflavor\\b', 'gm')
const str = `This product is without artificial fragrances, colorants and additional flavor.
This product without a doubt has the best flavor you will ever taste.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}