package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bwithout\b.*?(?:fragrances|colorants).*\bflavor\b`)
var str = `This product is without artificial fragrances, colorants and additional flavor.
This product without a doubt has the best flavor you will ever taste.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}