$re = '/\bwithout\b.*?(?:fragrances|colorants).*\bflavor\b/m';
$str = 'This product is without artificial fragrances, colorants and additional flavor.
This product without a doubt has the best flavor you will ever taste.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);