use strict;
my $str = 'Session::flash( \'error\', \'Only users with permission may view the directory user.\' );
Session::flash( \'error\', \'System user ID does not exist.\' );';
my $regex = qr/\bSession::flash\(\s*'([^']+)',\s*('[^']+')\s*\);/mp;
my $subst = 'flash($2)->$1;';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";