$re = '/\bSession::flash\(\s*\'([^\']+)\',\s*(\'[^\']+\')\s*\);/m';
$str = 'Session::flash( \'error\', \'Only users with permission may view the directory user.\' );
Session::flash( \'error\', \'System user ID does not exist.\' );';
$subst = "flash($2)->$1;";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;