re = /\bSession::flash\(\s*'([^']+)',\s*('[^']+')\s*\);/m
str = 'Session::flash( \'error\', \'Only users with permission may view the directory user.\' );
Session::flash( \'error\', \'System user ID does not exist.\' );'
subst = 'flash($2)->$1;'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result